OrdaSoft forum
Welcome, Guest
Please Login or Register.    Lost Password?
Errors by installing the component (0 viewing) 
BookLibary Component Support
Go to bottom Favoured: 0
TOPIC: Errors by installing the component
#424
Thobie (Visitor)
Fresh Boarder
Posts: 6
graphgraph
User Offline
Errors by installing the component 6 Years, 11 Months ago Karma: 0  
I am a new Joomla user. I tried to install the BookLibrary Component 1.5.3 Basic. Joomla version is 1.5.

Following things happens:

1.) The server of my provider works with PHP4. If I try to use the BookLibrary with "components"–>"book library"–>"books"or "categories" I get the following error:

Parse error: syntax error, unexpected '{' in /homepages/13/d230381840/htdocs/administrator/components/com_booklibrary/admin.booklibrary.class.ws.php on line 81

2.) But if I tell the server of my provider in the .htacceess file with

Script 1: .htaccess
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

to work with PHP5 the whole CMS – both site and admin login – crash down. But my provider has told me that this would be the wright way to upgrade the server and work with PHP5.

Any ideas how to solve the problem?


Thobie
 
Logged Logged  
 
Last Edit: 2010/01/09 23:03 By .
  The administrator has disabled public write access.
#425
Thobie (Visitor)
Fresh Boarder
Posts: 6
graphgraph
User Offline
Re:Errors by installing the component 6 Years, 10 Months ago Karma: 0  
I have solved the problem by myself with the help of a colleague of mine.

Only the first line of the script:

AddType x-mapp-php5 .php

had to be written into the .htaccess file. Then the server works with PHP 5 and all works fine.

Now I have another question:

I want to use the german language in the BookLibrary. On the website of Ordasoft is no BookLibrary Language page to find. Where can I find the language to upload it to my server?

Best



Thobie
 
Logged Logged  
  The administrator has disabled public write access.
#426
admin (Admin)
Admin
Posts: 4861
graph
User Offline Click here to see the profile of this user
Re:Errors by installing the component 6 Years, 10 Months ago Karma: 61  
Hi Thobie,

Please unzip file from attachment to
{yours site}/components/com_booklibrary/language
File Attachment:
File Name: german.zip
File Size: 9708


Thanks

Andrew
 
Logged Logged  
  The administrator has disabled public write access.
#428
Thobie (Visitor)
Fresh Boarder
Posts: 6
graphgraph
User Offline
Re:Errors by installing the component 6 Years, 10 Months ago Karma: 0  
Hello, Andrew,

thanks for the file. The Joomla site with the BookLibrary works now in german.

Another question:

If I want to refresh the information of a book with the ISBN by using amazon.de I get the error message:

Error: variable 'allow_url_fopen' in php.ini set 'Off'. Fetch information require this variable On

Does this depend on an error in the installion or the php.ini? Or does it depend on an error for the access to amazon.de that means an ID number or a password?

Best



Thobie
 
Logged Logged  
  The administrator has disabled public write access.
#429
admin (Admin)
Admin
Posts: 4861
graph
User Offline Click here to see the profile of this user
Re:Errors by installing the component 6 Years, 10 Months ago Karma: 61  
Hi Thobie,


If I want to refresh the information of a book with the ISBN by using amazon.de I get the error message

How you do first info fill for every book ?


Error: variable 'allow_url_fopen' in php.ini set 'Off'. Fetch
information require this variable On

That need for check - possible we use some functions or not
For correct work you need set variable 'allow_url_fopen' in php.ini to "On"
 
Logged Logged  
  The administrator has disabled public write access.
#441
Thobie (Visitor)
Fresh Boarder
Posts: 6
graphgraph
User Offline
Re:Errors by installing the component 6 Years, 10 Months ago Karma: 0  
Hello, Andrew,

If I want to refresh the information of a book with the ISBN by using amazon.de I get the error messageHow you do first info fill for every book ?
There is also one problem. If I add a new book only with the ISBN and choose the option "refresh information" with "Website – amazon.de" und save this option I get a clear white screen and nothing happens. No information will be added from amazon.de.

I have correctly added the informations in the backend for
a) Amazon Associate Tag,
b) Amazon AWSAccessKeyId and
c) Amazon Secret Key –
if that matter in any case to get informations of a book from Amazon.de

Error: variable 'allow_url_fopen' in php.ini set 'Off'. Fetch information require this variable OnThat need for check - possible we use some functions or not. For correct work you need set variable 'allow_url_fopen' in php.ini to "On"
There is one problem: I don‘t find any file which is called "php.ini" on my webspace to change the variable from "Off" to "On".

Best


Thomas
 
Logged Logged  
 
Last Edit: 2010/01/13 01:22 By .
  The administrator has disabled public write access.
Go to top
What are you looking for?
Anti-spam question: How many eyes has a typical person?