OrdaSoft forum
Welcome, Guest
Please Login or Register.    Lost Password?
OS Responsive Image Gallery module Support
Go to bottom Favoured: 0
TOPIC: Video not responsive
#35846
kcpopps (User)
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
Video not responsive 5 Months, 3 Weeks ago Karma: 0  
I'm using the gallery to show videos. Looks great but a couple things I would like some feedback on

First - using YouTube embed code opens a 560x315 video window.Fine on mobile phone but not on big desktop moniors.
The videos is not responsive. It opens at 560x315 and stays that size, regardless of viewing device. I'd like to open them at 1280x720 (max size) on desktops and I have done that by adjusting the embed code but it is not responsive and satys that size.
Can I make videos responsive?

Gallery Settings - Social Buttons
If I don't have at least one share button selected, it crashes the formatting around the pop up window - and still shows the share button , which I want gone.
I do not want to use this at all. How can I turn it off.
 
Logged Logged  
  The administrator has disabled public write access.
#35869
admin (Admin)
Admin
Posts: 5694
graph
User Offline Click here to see the profile of this user
Re:Video not responsive 5 Months, 3 Weeks ago Karma: 67  
Dear

In OesaSoft - OS Image gallery ordasoft.com/os-image-gallery.html
When I add video like HTML code:
Code:

<iframe width="560" height="315" src="https://www.youtube.com/embed/UAGNwAh45Xg" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>


it responsive for me!


Gallery Settings - Social Buttons

Could you give to us
full FTP and admin access
and our team will try to find solution special for You, FTP and admin access You can send to our contact form.
ordasoft.com/contact-us-form

Link on website.

Detail description: How reproduce error. Step by step. Detail description: how we may reproduce this.

Site Admin

username
password

FTP

FTP host
FTP username
FTP password

Thanks,
Andrew
OrdaSoft team.
 
Logged Logged  
  The administrator has disabled public write access.
#35872
kcpopps (User)
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
Re:Video not responsive 5 Months, 3 Weeks ago Karma: 0  
Re;Responsive video - yes that is the same code I'm using to place videos.
The Ordasoft Demo does the same thing. It opens at 560x315 but if you re-size the browser window to less than 560, scroll bars appear and the video stays at 560 in the frame.
Same result when I change that size to larger dimensions. Looks great unless browser window size is less than video width.

Thank you for the response!
I'll use the contact form for the other issue... regarding social buttons.
 
Logged Logged  
  The administrator has disabled public write access.
#35890
admin (Admin)
Admin
Posts: 5694
graph
User Offline Click here to see the profile of this user
Re:Video not responsive 5 Months, 3 Weeks ago Karma: 67  
Dear

For set video to Responsive in the OrdaSoft video gallery (ordasoft.com/os-image-gallery.html) you will need

in

you_site/templates/your_theme/css/style.css

at the bottom of the file, paste this code

iframe { max-width: 100%;}

Regards
Andrew
OrdaSoft team
 
Logged Logged  
  The administrator has disabled public write access.
#36022
admin (Admin)
Admin
Posts: 5694
graph
User Offline Click here to see the profile of this user
Re:Video not responsive 5 Months, 1 Week ago Karma: 67  
Dear

You need add
Code:

iframe { max-width: 100%;}


at the bottom of the file :
you_site/templates/your_theme/css/style.css


And for every video set something like below
Code:

<iframe width="1250" height="315" src="https://www.youtube.com/embed/UAGNwAh45Xg" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>


When I try edit your template I see:
Error You are not authorised to view this resource.

Regards
Andrew
OrdaSoft team
 
Logged Logged  
  The administrator has disabled public write access.
#36031
kcpopps (User)
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
Re:Video not responsive 5 Months, 1 Week ago Karma: 0  
My template does have a CSS folder:
you_site/templates/your_theme/css/theme.css
with a theme.css file in it.

It also has a Styles folder:
you_site/templates/your_theme/styles/mystyle/css/theme.css
there are 7 mystyle folders for seven styles, one of which is selected in template admin.

The one is the styles folder appears to be the current css file being used. I am assuming it overrides the file in the other folder. Changing it does make changes in frontend iframe display ---- but never what I want.

The theme.css file I have attached has other iframe references and I suspect there is some conflict. Could you have a look?

I've experimented with many changes to this theme.css file but I think it is now reverted back to the original - except, with the code you suggested at the bottom of the file.

The first video in the gallery has embed code for 1280x720 dimensions. The rest are at the default YouTube code of 560x315. Problem seems to be mainly with that first one, To replicate the problem (as I see it) go to my page on a desktop browser and size your browser window width down to where the gallery thumbnails stack themselves in rows of two or three. When in that narrow arrangement the iframe usually has too much height
 
Logged Logged  
  The administrator has disabled public write access.
Go to top
What are you looking for?
Anti-spam question: How many eyes has a typical person?