OrdaSoft forum
Welcome, Guest
Please Login or Register.    Lost Password?
Submenu only shows when clicking on menu (0 viewing) 
OrdaSoft template Support
Go to bottom Favoured: 0
TOPIC: Submenu only shows when clicking on menu
#15768
kevinas (User)
Fresh Boarder
Posts: 15
graphgraph
User Offline Click here to see the profile of this user
Submenu only shows when clicking on menu 1 Year, 4 Months ago Karma: 0  
Hi,

I have a problem with the menu.

I would like the submenu's to open on hover, but now it does not work like that. The template has a border-bottom as default. The submenu only opens on hover when the menu item is selected and the border-bottom lights up under it. On your demo it does show the menu's on hover. It also doesn't have the border-bottom. I know the border bottom is just styling and this can be taken away, but can't get the unselected menu items to open the submenu on hover.

Can you help me with this? Would be much appreciated.

Gr

Kevin
 
Logged Logged  
  The administrator has disabled public write access.
#15778
AnnaZh (Admin)
Admin
Posts: 226
graphgraph
User Offline Click here to see the profile of this user
Gender: Female Location: Kharkov, Ukraine
Re:Submenu only shows when clicking on menu 1 Year, 4 Months ago Karma: 7  
Dear Kevin,

Do you mean that submenus don't open when menu item isn't selected?
Or you are talking about hover on the screenshot?

Best Regards,
Anna
ordasoft.com
 
Logged Logged  
  The administrator has disabled public write access.
#15785
kevinas (User)
Fresh Boarder
Posts: 15
graphgraph
User Offline Click here to see the profile of this user
Re:Submenu only shows when clicking on menu 1 Year, 4 Months ago Karma: 0  
Yes I mean the hover is not working. Only when you click on the parent menu, so the top menu, then you get a bar under the menu and the submenu opens. The colorbar under the menu shows you where you are in your menu. When the menu that has a submenu is selected than only with that menu the submenu will come up on hover. The other menu's with submenu's will not open the submenu on hover.

I hope I am clear with my explanation, always hard to make it visual for you. Wait I will make a print for you. See the menu with the blue bar under it... that is the menu that will open the submenu on hover.. The menu's next to it, won't open on hover.

Hope this helps

Grz

Kevin
 
Logged Logged  
  The administrator has disabled public write access.
#15792
AnnaZh (Admin)
Admin
Posts: 226
graphgraph
User Offline Click here to see the profile of this user
Gender: Female Location: Kharkov, Ukraine
Re:Submenu only shows when clicking on menu 1 Year, 4 Months ago Karma: 7  
Hi Kevin,

I've tested the OS Joomla Blank template but haven't noticed any errors in its work.
Also seems that you already made changes in template, so we couldn't see and reproduce error without seeing new code.

Best Regards,
Anna
ordasoft.com
 
Logged Logged  
  The administrator has disabled public write access.
#15797
kevinas (User)
Fresh Boarder
Posts: 15
graphgraph
User Offline Click here to see the profile of this user
Re:Submenu only shows when clicking on menu 1 Year, 4 Months ago Karma: 0  
Hi Anna,

That is strange.

I think you must have a different version then.. I checked again... I put the template untouched on a local server and I got the same result again. I downloaded the lastest version for joomla 3x the one from oct 27. So what could be the reason for that?
 
Logged Logged  
  The administrator has disabled public write access.
#15802
kevinas (User)
Fresh Boarder
Posts: 15
graphgraph
User Offline Click here to see the profile of this user
Re:Submenu only shows when clicking on menu 1 Year, 4 Months ago Karma: 0  
Hi Anna,

I have to apologize to you, because the solution was really simple. Put submenu in module mainmenu on yes....Stupiddddddd!!!!!

Have a good day!
 
Logged Logged  
  The administrator has disabled public write access.
Go to top
What are you looking for?
Anti-spam question: How many eyes has a typical person?