OrdaSoft forum
Welcome, Guest
Please Login or Register.    Lost Password?
RealEstateManager component support
Go to bottom Favoured: 0
TOPIC: Japanese on RealEstateManager
#11467
nagata (User)
Fresh Boarder
Posts: 10
graphgraph
User Offline Click here to see the profile of this user
Japanese on RealEstateManager 2 Years, 6 Months ago Karma: 0  
Hello,

According to your instruction I have translated into Japanese, and the translated text are shown correctly.
But there is an issue.
Language for "Houses" and "categories" must be selected "All" for Japanese, otherwise no objects will be displayed.
My site is multilingual with German. For German pages I can select German for houses as well as categories.
However if choose Japanese from the pull down menu for houses or categories, nothing but the titles are shown.
And if I change the language from "Japanese" to "All", all the objects are displayed correctly.

In your document "How to add a new language to Real Estate manager" there are lines

-------------------------------------------------------------------------------------------------------------------------------------------------------------------
2. In the file RealEstateManager.xml in the directory /administrator/components/com_realestatemanager/ add the language entry for your language. This goes right after the entry language/english.php.
So if you use for example Dutch and Spanish on your site you would add those, like this:
lang/english.php
lang/dutch.php
lang/spanish.php
------------------------------------------------------------------------------------------------------------------------------------------------------------------

What does it mean?
I thought there is a line - lang/english.php - in the file "realestatemanager.xml", but I don't see any.
Or should I add
lang/english.php
lang/japanese.php
lang/german.php
somewhere in "realestatemanager.xml" ?

I hope you understand my problem and give me some tips or solution.

Best regards

Ichiro Nagata
 
Logged Logged  
  The administrator has disabled public write access.
#11485
admin (Admin)
Admin
Posts: 4856
graph
User Offline Click here to see the profile of this user
Re:Japanese on RealEstateManager 2 Years, 6 Months ago Karma: 61  
Hello,

That very important, at start every language file you see row:
$LangLocal = array('lang_code'=>'nl-NL', 'title'=>'Dutch';

so lang_code - must be exactly as use joomla for your lang, in this case for Dutch language and for dutch.php file !!!

and for see that language in language choose box - for every property - you need create In joomla language manager Dutch content language with code 'nl-NL'

for Japanese - all exactly


realestatemanager.xml - that file you need edit only if you need inner real estate manager menu on your language, other please not edit it

Thanks,
OrdaSoft team
 
Logged Logged  
  The administrator has disabled public write access.
#11487
nagata (User)
Fresh Boarder
Posts: 10
graphgraph
User Offline Click here to see the profile of this user
Re:Japanese on RealEstateManager 2 Years, 6 Months ago Karma: 0  
Hello,

Thank you very much for a reply.

Yes, on my "Japanese.php"

$LangLocal = array('lang_code'=>'ja-JP', 'title'=>'Japanese';

is already there

Yes, Japanese is set as a Joomla content language on the Joomla language manager.
So, the basic multilingual functions work well.

In fact, it works fine. It means that the Japanese pages as well as Japanese RealEstate properties are shown correctly in Japanese.
However I have to choose "All" to display the pages.
Please see the attached file.

I hope you understand my problem.
Thank you and best regards,
Ichiro Nagata
 
Logged Logged  
  The administrator has disabled public write access.
#11536
admin (Admin)
Admin
Posts: 4856
graph
User Offline Click here to see the profile of this user
Re:Japanese on RealEstateManager 2 Years, 6 Months ago Karma: 61  
hello,

There are as me seem possible 2 problems:
1. may be problems in how you wrote word Japanese - at japanese - may be there are some special letter what kill all content
2 or lang_code=>'ja-JP' not full exactly equal for code what you set in language content - in Joomla language manager or it not full equal to lang code - what set for your Japanese frontend lang file, may be it set as 'ja-jp' ?!

If you will can fix that - please send admin and FTP access to your site and we will check where error.

Your account details you may send with help OrdaSoft contact form

Thanks,
OrdaSoft team
 
Logged Logged  
  The administrator has disabled public write access.
#11549
nagata (User)
Fresh Boarder
Posts: 10
graphgraph
User Offline Click here to see the profile of this user
Re:Japanese on RealEstateManager 2 Years, 6 Months ago Karma: 0  
Hello,

Thank you very much.
But how can I send you admin/access-password personally?

ichiro nagata
 
Logged Logged  
  The administrator has disabled public write access.
#11564
admin (Admin)
Admin
Posts: 4856
graph
User Offline Click here to see the profile of this user
Re:Japanese on RealEstateManager 2 Years, 6 Months ago Karma: 61  
hello,

your account details you may send with help OrdaSoft contact form
ordasoft.com/About-us/OrdaSoft.html

Please together - send your problem details

Thanks,
OrdaSoft team
 
Logged Logged  
  The administrator has disabled public write access.
Go to top
What are you looking for?
Anti-spam question: How many eyes has a typical person?