OrdaSoft forum
Welcome, Guest
Please Login or Register.    Lost Password?
SEF Translate Big big Problem!! (0 viewing) 
SEF Translate component support
Go to bottom Favoured: 0
TOPIC: SEF Translate Big big Problem!!
#12134
azdora (User)
Junior Boarder
Posts: 27
graphgraph
User Offline Click here to see the profile of this user
SEF Translate Big big Problem!! 2 Years, 7 Months ago Karma: 0  
Hello,
i got a problem in CPU usage too high from our hosting service.
at the same time i got too many traffic in google api translate (1,48 MB in one day!!!)

and we dont have so big traffic in our site (600 pages/day).

Looking with our hosting support we found this:


I checked the executions of your account from the last few days and here is the result:

Today:
3030 /home/mangiama/public_html/index.php
1257 /home/mangiama/public_html/components/com_seftranslate/translate.php
182 /home/mangiama/public_html/administrator/index.php

Yesterday:
7115 /home/mangiama/public_html/index.php
2326 /home/mangiama/public_html/components/com_seftranslate/translate.php
390 /home/mangiama/public_html/administrator/index.php

Monday:
6056 /home/mangiama/public_html/index.php
1943 /home/mangiama/public_html/components/com_seftranslate/translate.php
548 /home/mangiama/public_html/administrator/index.php

and after this I have checked in details and found some quite large database tables:

avjos16_seftranslate_urls - 137MB
avjos16_finder_terms - 27MB

Such large databases will cause slow queries, thus slower loading times and more CPU usage. I would strongly check and optimize them to resolve the issue. Based on your script executions it seems that this script:

home/mangiama/public_html/components/com_seftranslate/translate.php

is one causing the issue i.e. using a lot CPU time.

and when i try to access to >component>sef translate>URLs i get this:
Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 76740 bytes) in /home/mangiama/public_html/libraries/joomla/database/database/mysqli.php on line 498

Please give me the solution........ASAP!!

Giovanni
 
Logged Logged  
  The administrator has disabled public write access.
#12142
azdora (User)
Junior Boarder
Posts: 27
graphgraph
User Offline Click here to see the profile of this user
Re:SEF Translate Big big Problem!! 2 Years, 7 Months ago Karma: 0  
Hello.
i provide some add info about the problem:
- after cleared cache i get access to sef translate URLs in backend, but one hour later i see that all URL (as in sitemap) are translated again, all. If i clean cache, component translate again all urls. So it cost much bandwidht and quota in API's.

In previous message, i reported notes from hostin support, so "your account" is my account.

Please give me some help!!!!!!!
 
Logged Logged  
  The administrator has disabled public write access.
#12154
admin (Admin)
Admin
Posts: 4874
graph
User Offline Click here to see the profile of this user
Re:SEF Translate Big big Problem!! 2 Years, 7 Months ago Karma: 61  
hello,

Please use redirect mode for sef translate - only in that case component use cache.

Please check - SefTranslate setting, please check cache time what you set.

next please check Post and Cookies - what you except from equal pages check, You may set except ALL

Thanks,
OrdaSoft team
 
Logged Logged  
  The administrator has disabled public write access.
#12162
azdora (User)
Junior Boarder
Posts: 27
graphgraph
User Offline Click here to see the profile of this user
Re:SEF Translate Big big Problem!! 2 Years, 7 Months ago Karma: 0  
Hello,
i disabled Sef translate module.
in component settings the cache is set to 20 minutes.
POST and COOKIE have no selection, what i have to do?

The problems comes from the script "translate.php" continues to produce too many executions (with got 10 page views (7 in original language), it's not possible that i find 100 urls translated......

Waitng and hoping...

giovanni
 
Logged Logged  
  The administrator has disabled public write access.
#12163
admin (Admin)
Admin
Posts: 4874
graph
User Offline Click here to see the profile of this user
Re:SEF Translate Big big Problem!! 2 Years, 7 Months ago Karma: 61  
Hello,

set cache time - more big, some day.

we any way - if page change - will re translate it.

select check boxes for POST and COOKIE - that except POST and COOKIE from compare URLs


translate.php - will call for every translated pages, but for some pages - it will return page from cache, for other pages - it will do full page translate

Thanks,
OrdaSoft team
 
Logged Logged  
  The administrator has disabled public write access.
#12169
azdora (User)
Junior Boarder
Posts: 27
graphgraph
User Offline Click here to see the profile of this user
Re:SEF Translate Big big Problem!! 2 Years, 7 Months ago Karma: 0  
Hi, let me explain the problem.

Cache cleared.
In >components>sef translate>URLs>No urls.
after 20 minutes:
8 visits - 12 page viewed and translated.
In >components>sef translate>URLs>80 Page translated (note that are not common urls, and NOT VIEWED, page refering to tags called in a page not viewed.

Shoul i reinstall?

Giovanni
 
Logged Logged  
  The administrator has disabled public write access.
Go to top
What are you looking for?
Anti-spam question: How many eyes has a typical person?