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SEF Translate - Joomla solution for automatic
translation

SEF Translate is Joomla extension for automatic translation that combines handiness of Joomla
translation module (set easily methods of translation (Instant, jQuery or Redirect), size and style of
flags, layouts of module, etc) and power of Joomla translation component (it helps to choose Google
translate or Bing translator, set needed cache options, translation algorithms, edit automatically
translated pages, URLs and more). Our automatic Joomla language translator is not only translates 98%
of Joomla site (including all website content, iFrames, URLs and meta data), but also adds chosen
languages in website's sitemap hence improve visibility and rank of translated content in search engines
on other languages (SEO feature).

Complete automatic translations of Joomla websites on 90+
languages

Bing/Microsoft Translator supports 50 languages that cover more than 95% of worldwide gross
domestic product (GDP). Also Microsoft Translator gives a free quota up to 2 Million characters per
month.

Google Translate supports 90+ Languages, but provides only paid automatic translation services.

Nice-looking language bar in SEF Translate

In SEF Translate - Joomla module for automatic translations you could control a wide range of options,
so you can be sure that it fits perfectly to your website's look and feel:

* 3 styles of translation module: Dropdown, Flags, Flags & Dropdown
* 2 types of flags are available: Flat & Shiny

* 5sizes of flags: 16px,24px, 32px, 48px, 64px

Google Translate & Bing/Microsoft Translator in SEF Translate

Choose online translator that fits best for your needs - Google Translate API or Bing/Microsoft
Translator API.

Difference between them lies in the number of translated languages and the price for the
translation. Unlike Google Translate, Bing/Microsoft Translator provides free quota (up to 2,000,000
Characters/month), so you can test it before purchase. At the moment Bing/Microsoft Translator
supports 50+ languages, in contrast to Google Translate that provides translations on 90+ languages.
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5 positions/layouts for SEF Translate module

In SEF Translate - Joomla module for automatic translations you are able to choose position for
displaying SEF Translate module easily using pre-defined layouts:
Default, Top, Bottom, Left, Right

Ability to edit automatically translated pages & URLs in admin
area

Automatic translation is not always accurate enough. You can use Manager of translated pages
& URLs in SEF Translate component to correct automatic translations that you don't like manually.

SEO & SEF Features

Sitemap is one of the important ways of communication with search engines. Adding new
languages to Sitemap improves visibility of translated pages by search engines and speed up their
indexing (search engines get informed immediately about pages on other languages).SEF Translate
Joomla component enables to add as many languages to website's Sitemap as you want. Furthermore
you can create Sitemap in two formats HTML (for Yahoo! and MSN) and XML (for Google).
One more SEF feature is translation of Meta tags. For example, Meta description on other languages
will be shown in the search snippet (displayed beneath a listing in the search results) of that language
that could draw a much higher click-through rate of foreign searchers to your page.
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How To Install SEF Translate Component and
Module?

The procedure is the same as for most Joomla extensions. To install SEF Translate Component
and Module you need:

1. Download the extensions (component and module) to your local machine as a zip file package
2. From the backend of your Joomla site (administration) select Extensions -> Install/Uninstall.

3. Click the Browse button and select the extensions (component and module) on your local
machine.

4. Click the Upload File & Install button.
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How to configure SEF Translate (Basic)

Follow this steps to configure SEF Translate Basic (free version). If you have Pro or Pro
Commercial version, please read this tutorial in the next article How to configure SEF Translate Pro.

1. Install SEF Translate component.

2. Install SEF Translate module.

3. Go to Extensions -> Module Manager -> SEF Translate module.
3.1. Set Translation Method for you site.

If you select Instant method, your web pages will be translated instantly with help of Google
translator.

If you select jQuery then your site will be translated without redirect when the user clicks on
language flag or chooses language from the drop-down list.

If you select Redirect then your website will be redirected and page will be opened on selected
language.

3.2. Enter languages which you want to display in drop-down List on frontend. If you choose no
language, drop-down list won't be shown on frontend.

3.3. Enter languages which you want to display in the form of Flags on frontend.

4. Go to Components -> SEF Translate -> Settings -> tab General

4.1. Website main language. Select main language of your website.

4.2. Choose Bing or Google Translate API. For now we support Bing translate API and Google
Translate API. Bing is selected as default, because it is free (up to 2,000,000 Characters/month)
and supports such languages. Google provides paid Translate API, but it supports almost all
languages. See pricing here.

4.3. Google API Translate. Add Google API key. Get started here.

4.4. Bing Translate API. Insert your Bing Translate API here (Client Secret and Client ID). Read
How to get Bing Translate API?

5. Go to Components -> SEF Translate -> Settings -> tab Sitemap
5.1. Sitemap Languages. You need to choose languages on which your website will be
translated. This option is required.
5.2. Use cache for Sitemap. Select use cache for Sitemap or not.
5.3. Clear cache Sitemap. Click on button to clear cache Sitemap.

6. To view Sitemap you have to create menu item of SEF Translate component.
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How to configure SEF Translate (Pro)

At first glance the configuration of SEF Translate Joomla extension may seem difficult, but all
steps are described in details, so follow them and make your Joomla website multilingual. If you have

free version of SEF Translate, please read this tutorial How to configure SEF Translate (Basic).
Before you start please read this note.

IMPORTANT:
SEF Translate component does not work together with component JoomFish.

To start use SEF Translate Pro you need:

1. Install SEF Translate component.
2. Install SEF Translate module.

3. Go to Extensions -> Module Manager -> module SEF Translate

Tite* | SEF Translate

Module Menu Assignment Module Permissions Advanced options

SEF Translate

Automatic translation of ywour website with help of Google and Bing Translation AP

Module position Right v
Translation Method Redirect b
Show Message Yes Mo

Message Text This page is not translated

Use SEF URLs

VYes Mo
Hide Module Yes Mo
Language Flags Chinese_simplified 3 | | English

French * || German * || ltalian
Japanese ¥ || Portuguese

Spanish *

SefTranslate images Yes Mo
Flag Size 16 -
Flag Type shiny -
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3.1. Choose layout for module SEF Translate.

There are 5 module positions: default (to use standard Joomla position), top, bottom, left and
right. In order to place SEF Translate module in one of these positions you have to set any standard
Joomla position and choose one of predesigned positions of SEF Translate Joomla module.

3.2. Set translation method for your site

If you select Instant method, your site will be translated instantly, but content won't be cached,
so you won't be able to edit pages and URLs. To edit pages you need to set up Redirect method of
translation.

If you select jQuery then your site will be translated without redirect when the user clicks on
language flag or chooses language from the drop-down list.

If you select Redirect then your website will be redirected and page will be opened on selected
language. If you use Redirect translation method and cache pages, when user is logged in Joomla, his
page won't be saved in cache and translation method will be switched to Jquery. This option is
necessary for security of user's data.
3.3. Select whether or not show the message that page is not translated

3.4. Enter message that page is not translated

3.5. Use SEF URLs (only for Redirect method). This option is used for correct definition of URLs for
translation. If you use search engine friendly URLSs on your site, set Yes, if you don't use SEF URLs on
your site, set No.

3.6. Hide module. Set to Yes in order to hide module from logged in users. Set to No in order to show
module to logged in users. This is necessary to save translation quota.
3.7. Enter languages which you want to display in the form of flags on frontend.
3.8. SEF Translate images. If you want to merge flags from SEF Translate and Joomla language
Switcher, choose what flags will be displayed. Set to Yes if you want to display flag images from SEF
Translate (recommended).

3.9. Choose the size of flags. Available sizes: 16px, 24px, 36px, 48px, 64px
3.10. Choose style of flags (flat or shiny)

3.11. Enter languages which you want to display in drop-down list on frontend. If you choose no
language, drop-down list won't be shown on frontend. This option is available only if you choose
default module position.

4. Go to Components -> SEF Translate -> Settings -> tab General
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General Cache Map

Website Main Language English v

[::Q:;] @(’]

Translation Algorithm 1 -

Untranslatable Pages ()
P
Place to Save Cache Files r (_)
Choose Bing or Google APl Bing v (_)
Google AP Key ()
Bing AP Client Secret (:)
Eing AFI Client 1D .Z.
Joomla multi languages: R[] Yes (}
Translate lframes: (N [] Yes (}
Translate Urls: Mo Tes (:)
User IP Mo Yes @
Debug RIS Yes (_)

4.1. Website main language. Select main language of your website.

4.2. Translation algorithm (By default 1). You need to check what algorithm works the best for
your website.

4.3. If you don't want to translate some pages, enter their URLs in Untranslatable pages. Each
URL should be written from new line.

4.4. Place to save cache. You can save cache in Files or in Database. If you save cache in
Database, you will save quota for hosting, also you will have opportunity to manually correct
pages which were translated and set these pages as base. Base URLs are used as main page for
translation for this URL and this language - without checking cookies and post values.

4.5. Choose Bing or Google Translate API. For now we support Bing translate API and Google
Translate API. Bing is selected as default, because it is free (up to 2,000,000 Characters/month)
and supports such languages. Google provides paid Translate API, but it supports almost all
languages. See pricing here.

4.6. Google API Key. If you have chosen to use Google Translate API, get started here.

4.7. Bing Translate API. Insert your Bing Translate API here. Read How to get Bing Translate
API?

4.8.Joomla multi languages. If you want to merge flags from SEF Translate and Joomla
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language Switcher in one string of flags, set this option to YES

4.9. Translate iFrames. Set to YES if you want to translate iFrames with help of SEF Translate.
4.10. Translate URLs. If you want URLSs to be translated, set option to YES.

4.11. User IP. Set to Yes if you want to supply the IP address of the end-user on whose behalf
the request is being made. This option is used if there are some problems with Google
translation. Goggle limits the translation quota without specifying user IP.

4.12. Debug. Option for error checking. If some page after translation turns to blank page, set
this option to Yes in order to check the problem.

5. Go to Components -> SEF Translate -> Settings -> tab Cache

Sef Translate: Settings

URLs

Setting General Cache Map

About

Help Caching Use global v

Cache time 300

Exclude from unigue cache:

FOST o All

y
COOKIE s All

y
Clear cache T Clear..

5.1. Caching. Select Yes to use caching for translated page. This will help you to speed up your
website.

5.2. Cache time. Set time (in minutes) after which cache will be refreshed.

5.3. For identification pages of the website (while creating cache) we use
POST+COOKIE+URL. If you have pages which after reload have different value for some keys
in POST or in COOKIE (for example Google analytics), please set these keys to be removed
from cache page name definition.

In order to ensure website security SEF Translate turns off Cache and switches to AJAX
automatically when using Redirect while User is logged on the site.

HINT: We usually remove from cache all COOKIES.
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5.4. Clear Cache. Option gives ability to clear cache.

6. Go to Components -> SEF Translate -> Settings -> tab Sitemap

Sef Translate: Settings

URLs
Gener: Cache [
Settings General Cache Siternap
About
Help Sitemap component KMap v
EBasque -
Eelarusian
Bengali
Bihari
Sitemap languages Breton
Bulgarian

Burmese
Catalan

Chernkas A

it.com/joomla-33-testindex . php?
ftranslate & ml&tmp

¥ML sitemap URL

oomla-33-testdindex php?

HTML sitemap URL
l n=com_seftranslate

Use cache for siternap Mo Yes
Add language to cache + Add
Clear cache sitemap Cache is clear.

IMPORTANT: To ensure correct work of Sitemap it is necessary to install SOAP client (php
extension) on the server and included options that are in the configuration file (php.ini) and
which are responsible for supporting the SOAP.

6.1. SiteMap Component. Select component that is used to generate a sitemap.

If you set Not use or choose component that is not installed you will get site map generated only
for main menu.

If you choose installed on your site Sitemap component and select some of SiteMap languages,
SEF Translate will translate the Sitemap on all selected languages.

6.2. Sitemap Languages. You need to choose languages on which your website will be
translated. This option is required.

6.3. XML Sitemap URL. It is link on XML Sitemap for registration on Search Engines like
Google or Yahoo.

6.4. HTML Sitemap URL. It is link for HTML Sitemap for displaying to users.

6.5. Use cache for Sitemap. Select use cache for Sitemap or not.

6.6. If you have very long Sitemap or while creating translation of Sitemap you have error you
can Add languages on you cached Sitemap.

6.7. Clear cache Sitemap. Click on button to clear cache Sitemap.

7. To view Sitemap you have to create menu item of SEF Translate component.

IMPORTANT: It is necessary to add this page to Untranslatable pages in Components -> SEF
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Translate -> Settings -> tab General

8. If you choose Redirect you need configure redirect with built-in functions of Joomla or an additional
component such as sh404SEF.

Next you have to add in .htaccess file following piece of code after words RewriteEngine On and
activate the option in the settings of Joomla. If you don't have .htaccess file in your website home
directory, copyhtaccess.txt and rename it to .htaccess

Insert this code in file .htaccess:

RewriteRule ~([a-z]{2})/(.*)$ components/com_seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

RewriteRule ~([a-z]{2})$ components/com_seftranslate/translate.php?seflang=%$1 [L,QSA]
RewriteRule ™ (pt-PT)/(.*)$ components/com_seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

RewriteRule ™ (pt-PT)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(zh-CN)/(.*)$ components/com_seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

RewriteRule ™~ (zh-CN)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ™~ (zh-TW)/(.*)$ components/com_seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

RewriteRule ~(zh-TW)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(bs-Latn)/(.*)$ components/com_seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

RewriteRule ~(bs-Latn)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(ceb)/(.*)$ components/com_seftranslate/translate.php?seflang=$1&sefurl=$2
[L,QSA]

RewriteRule ~(ceb)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(hmn)/(.*)$ components/com_seftranslate/translate.php?seflang=$1&sefurl=$2
[L,QSA]

RewriteRule ~(hmn)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(mww)/(.*)$ components/com_seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

RewriteRule ~(mww)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(yua)/(.¥)$ components/com_seftranslate/translate.php?seflang=%$1&sefurl=$2
[L,QSA]
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RewriteRule ~(yua)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]

If you want to translate website with subdomain you should insert
RewriteBase /subdomain_name/

before piece of code

RewriteRule ~([a-z]{2})/(.*)$ components/com seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

If you have Joomla Native multi language site, better not to redirect every language, but to
redirect languages from SEF Translate only. Languages that you set in Joomla content (native
Joomla languages) shouldn't be redirected. Below is example of language configuration for
French, Russian and Chinese languages (that is used in SEF Translate):

RewriteRule ~(fr)/(.*)$ components/com_seftranslate/translate.php?seflang=$1&sefurl=$2
[L,QSA]

RewriteRule ~(fr)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(ru)/(.*)$ components/com_seftranslate/translate.php?seflang=$1&sefurl=$2
[L,QSA]

RewriteRule ~(ru)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]
RewriteRule ~(zh-CN)/(.*)$ components/com_seftranslate/translate.php?
seflang=$1&sefurl=$2 [L,QSA]

RewriteRule ~(zh-CN)$ components/com_seftranslate/translate.php?seflang=$1 [L,QSA]

8. To view translated file (if you choose place to save cache Files in Components -> SEF
Translate — Settings -> tab General) and edit it manually you need to go to:

{your site}/components/com_seftranslate/translate.php

At the end of all your translated pages you will see a row:

sef translate:99107586c60db878c4f2430139b387dd.csh

where 99107586c60db878c4f2430139b387dd.csh - file with translation from the folder:
{yours site}/components/com_seftranslate/cache/

IMPORTANT: Please remember - this file will be rewritten when cache time will expire. It

refers both to Fileand Database.
Read also How to edit translated pages manually in the next article

© OrdaSoft - All rights reserved Page 13 of 21
If you can't find an answer, please check our forum


http://ordasoft.com/Forum/

How to edit translated pages and URLSs?

If you don't like automatic translation which Bing or Google provides, you can manually edit all
translated pages and URLs. (Only for SEF Translate Pro Commercial version)

1) To edit translated text manually, first you need to turn off editor in Joomla global settings.

Menus - Content -

e —

Contacts
Site Offline T “ Use URL Rewriting Yes Mo
Articles

Smart Search
Offline Message Use Custom Message i Adds Suffix to URL
Installation Manager

Joomlal Update
Custom Message maintenance.<br /> Please Unicode Aliases

Language Manager check back again soon.

Media Manager )
Include Site Mame in Page Titles | Mo hd
Menus Manager Offline Image @ Select x

Messaging

Cookie Settings

Module Manager Mouse-over Edit Icons for Modules A
MNews Feeds
Flugins M r Default Editor * Editor - None -
ugins Manager Cookie Domain
FPost-installation Messages I TRV TTTLT
i Default Captcha * Editor - Mone
Redirect r Coakie Path
Search y y
Tags Default Access Level e
Template Manager
Default List Limit 20 >
Users Manager
Weblinks
Default Feed Limit 10 -
mapx
Feed Email Address Author Email -

If you want to edit pages with help of MCE editor you have to set in editor options:
Functionality -> Extended;
Entity Encoding -> Raw;
Prohibited Elements -> Any text;
Custom plugin -> Full page.
If you want to use other editor, please check manual for that editor.

2) After disabling editor go to Components -> SEF Translate -> tab Translation Pages

SEF Translate: Translation pages Joomial

W UseashasePage | ¥r UnuseasbasePage | # Manualytransiated | 4@ Autotransiated [ EditPage | 3 Delete Page

SEARCH: @  selectlanguage v @ | Manualyorautotrans v (@) | Baseornotbasepage v (@) Al

Translation Pages

Translation urls

Settings
About MANUALLY CHANGED BASE PAGES

# URL LANGUAGE CHECKED OUT
Help (i) @

6 I http:/fordasvit.com/joomia-sef-translate/bn/index.php/all-flags I Bengali o o

20 http:ffordasvit.comdoomla-seftranslate/de/ German o o
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Use as base page. Base page will be translated without checking Cookie and Post data.
Unuse as base page.

Manually translated. Mark pages as manually translated if you have made corrections there. Then
when the cache will renew, your changes won't be lost.

Auto translated. Automatically translated pages will be updated, when the cache will renew.
3) Then click on the URL of translated page that you want to change manually.

~ Save URL € Cancel

URL
http ardasvit.comsjoomia-33-test/des

Page content

Soft XMLHTTE “}catch(e){Hii(r{r.open("GET"," /" tru
dy(function(f
B0 teeltp " html”: true,"container”: "body "}

N

Language
Serman

Manual translated or auto

nanual changed -
Use as base url

Use as Base Url -

Cookies:

Posi:

Last edit date

2015-06-08 12:17:27

Here you can change automatically translated words.
Don't forget to set page as Manually changed to prevent updating it when cache expires.

4) To change translated URLs manually, navigate to Components -> SEF Translate -> tab
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Translation URLs

SEF Translate: Translation urls

# Manuallytranslated | 4@ Autotranslated | [@ Editurl | ¥ Delete url

Transiaton Pages SEARCH: @ | selectianguage v @ | Manualyorautotrans v (@)
Translation urls
Settings
About
i URL ORIGIN URL DESTINATION LANGUAGE
Help
23 index php/all-flags/languages-from-bing-translator index php/All-flags/Sprachen von Bing Ubersetzer German
index.php/layouts-of-sef-translate/bottom-layout-of-sef- index php/disefios-de-seftraducir/Fondo-disefio-te-sef- Spanish
. =1
translate traducir P

34 index.php/layouts-of-sef-translate/top-layout-of-sef-translate index php/disefios-de-sef-traducinTop-disefio-te-sef-traducir  Spanish

7 index.php/all-flags index.php/kaikki liput Finnish

5) Click on URL that needed to be changed and in URL Destination correct the translation of URL to
your liking.
Also set Manually changed in option Manual translated or auto in order to not update URL when cache

renews.

SEF Translate: Translation Url

" Save url € Cancel

URL origin:
index.php/all-flags/languages-from-bing-translator

URL destination:
index php/All-flags/Sprachen von Bing Ubersetzer

Language:
German

Manual franslated or auto:
Auto translated ¥

Last edit date:

2015-09-24 17:29:06
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How to create Joomla multilingual Sitemap
using SEF Translate?

To create multilingual Sitemap on Joomla based website with help of SEF Translate, Joomla
translation component, you need to download and install mapX (Xmap old). Download it for free here

1) After installation, go to Components -> mapX
and click on New button for creation new Sitemap.

i= mapX: New Sitemap

+ Save & Close =+ Save & Mew [n Save as Copy € Close

Title * Alias
Menus Intro Text Options Ping Publishing Permissions
Title Priority
f Main Menu 05 v

2) Then navigate to Components -> SEF Translate -> Settings -> tab Map and in Sitemap languages
choose languages on which Sitemap should be translated. To select several languages, press Ctrl

Sef Translate; Settings

[ —
& Apply
LRLs
General Cache Sitemap
About
Help Sitemap component KMap v
Basque a
Belarusian
Bengali
Bihari
Sitemap languages Breton
Bulgarian
Burmese
Catalan
Chernkee T

dasvit.com/joomla-33-test/index php?
XML sitemap URL N ! N P
=xml&tmpl=component

http joomla-33-testdindex.php?

HTML sitemap URL ftranslate

Use cache for sitemap N Yes
Add language to cache + Add
Clear cache sitemap Cache is clear.

Under Sitemap languages, you can see XML Sitemap URL which you can use for submitting to Search
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engines and HTML Sitemap URL that allows users navigate website easily.

3) To display multilingual Sitemap at the Frontend, you should create menu item for it in SEF
Translate, Joomla translation manager:

Menu Item Type

SEF Translate

SEF Map Displays the frortpage of a application

Search

4) In final you get multilingual Sitemap in Joomla website just in three easy steps.

Main Menu

- Home
+ Al Languages
s Languages from Bing Translator
© Languages from Google Translate
= Layouts of SEF Translate

© Top Layout of SEF Translate
s Bottom Layout of SEF Translate
e Left Layout c EF Translate
e Right Layout of SEF Translate
o Default Layout of SEF Translate

- Styles & Sizes of SEF Translate
© SEF Translate Language flags 16px
+ SEF Translate Language flags 24px
e SEF Translate Language flags 32px
o SEF Translate Language flags 48px
© SEF Translate Language flags 6apx
© SEF Translate Language flags: Flat
+ SEF Translate Language flags: Shiny

* Sitemap SEF Translate

Main Menu

+ Accueil
- Al Languages
o Langues de Bing Translator
o Langues de Google Translate
- Layouts of SEF Translate
+ Haut de la page mise en page de SEF traduire
= Disposition de fond de SEF traduire
o Définition de mise en page gauche du SEF
© Bonne mise en page de SEF traduire
o Définition de disposition par défaut du SEF
- Styles & Sizes of SEF Translate
s SEF traduire langue drapeaux : taille 16px
s SEF traduire langue drapeaux : taille 24 PX
o SEF traduire langue drapeausx : taille 32px
o SEF traduire langue drapeaux : taille 48px
o SEF traduire langue drapeaux : taille 64px
= SEF traduire langue drapeaux : plat
s SEF traduire langue drapeaux : brillant
- Plan du site SEF traduire

Main Menu

= Startseite

- All Languages
© Sprachen von Google berse

+ Layouts of SEF Translate

s Top Layout der SEF Gbersetzen
o Unteren Layout d EF lbe
o Linken Layout der SEF ibersel
© Richtige Anordnung der
= Standardlayout der SEF iibersetzen

+ Styles & Sizes of SEF Translate
s SEF lberset rache Flaggen: 16px Groke
o SEF Flaggen: GraGe 24px
o SEF Flaggen: 32px
° SEF O Flaggen 48px
s SEF O Flaggen: Gréfe 64px
s SEF Flaggen: flach
o SEF Flaggen: glanzend

- Sitemap SEF Gber

© OrdaSoft - All rights reserved Page 18 of 21
If you can't find an answer, please check our forum


http://ordasoft.com/Forum/
http://ordasoft.com/SEF-Translate-Documentation/how-to-create-joomla-multilingual-sitemap-using-sef-translate.html#img4

How to get free Bing Translate API?

If you decide to use Bing Translate API you need to do following steps:

1) Register or log in your Windows Live Account

B® Microsoft

Create an account

You can use any em ail address as the usernam e for your new Microsoft account, including
addresses from Oudook.com, Yahoo! or Gm ail. If you already sign in to a Windows PC, tablet or
phone, Xbox Live, Oudook.com or OneDrive, use that account to sign in.

First name Surname

Username

| someone@exam ple.com |

Get a new email address

Password

8-character minimum; case-sensitive

Re-enter password

Country/region

| United Kingdom b |

Date of birth

| Dany - ” Month - ” Year - |
Gender
| Select.. v |

Help us protect your info

Your phone number helps us keep your account secure.

Country code

| United Kingdom (+44) -

Phone number

We want to make sure that a real person is creating an account

ﬁ'_ MNew
= Audio
&

Enter the characters you see

|« Send me promotional offers from Microsoft You can unsubscribe at any time.

Click Create account to agree to the Microsoft Services Agreem ent and privacy and cookies
statement

Create account
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2) Subscribe to the Microsoft Translator API on Azure Marketplace. Basic subscription (up to 2 million

characters per month) is free. Translation of more than 2 million characters per month requires a

payment. You can pick from any of the available subscription offers.

Microsoft Azure
Marketplace

Home > Data > Microsoft Translator

" g
&R

Learn Applications Data My Account Fublish
Microsoft Translator 2,000,000 0.00 P
Characters/month
_________________ per mortth
bata [ Sionur ]
Published by Microsoft Translator 4,000,000 1 376,33 P
Categaries Communications, Machine Learning, Peference, = SIEEIREn | per month
Developer Services, High Tech & Electronics
Date added: 31.08.2011 6.000.000 o
. . 2 064,49
Get support for this offering Qﬁg[qgtief’s{mqrjt’h per month
Microsoft Translator is & WEB API that enables Automatic Translation (Machine .
Translation) of text beween any of the 50 supported languages.This state-of-
the-art statistical machine translation APl powers billions of franslations every ?ﬁga(‘)cglssgr(n)uonth 2 7:3%;2? P
day. It also provides additional functionality such as language detection and
pre- and post-editing customization with, respectively, the Translator Hub and
C ative Translation Framework (CTF).
The APl is used in the translation features of many Microsoft products, such as g—g;ggg;r?nont?‘ 5 505-?“0 P
Office, SharePoint, Lync, Yammer, Visual Studio, and Bing. talso powers  — oot
numerous consumer translation apps (ineluding Microsoft's own Translator '
apps on Windows and Windows FPhaone). For quick and easy website
ranslations, customers can integrate to their site, blog, or SharePoint site, the gr?a;gggfrgnonl?‘ 10 322!14 P
Translator Web Widget. . SEREEESSLLon
To get started using the Translator API, go to .
www MicrosoftTranslator.comiGetStarted
gfl—,O?O{,OOt(g 19 819,09 £
aracters/mon
""""""""" T
128,000,000 36 403,82 F
Characters/month per month
Sample Images Details Publisher Offer Terms
250,000,000 70 708,75 P
Charactersimonth per morth
500,000,000 137 460,56 P
(e e B ) per morith
635,000,000 172 040,75 P
Charactersimanth per morth
1,000,000,000 206 448,90 P
slator al s cl th per morith
o o T
o vousiste Wl Windowsproee [ s

3) Register your application. After you have logged in Microsoft Azure Marketplace (using Microsoft
account) go to My account -> Developers -> Register.

Microsoft Azure
Marketplace

The Microsoft Azure ™ Mar

Learn Applications Data My Account

Developers

enables de

Fublish

1on the Mar

Learn More

o Using Marketplace Data in your Application

o Developing an Application to Sell on the Marketplace

o Developing an Application using the Microsoft Translator Service
o Check outthe latest Marketplace Code Samples

REGISTER
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There you should fill in these fields:

Microsoft Azure

Marketp|ace Learn Applications Data My Account Publish

Register your application

ClientID

Your application's ID. It can be a mix of numbers, letters, hyphens and underscores

Name

The name of the application that will be displayed to the user when asking the user's permission to access their
account

Clientsecret

Pa: ord for your 1. Keep it secret. You man provide your own, or use the provided one above.

Redirect URI

URL to redirect atthe end of the consent flow. Clients that don't use the consentflow (e.g. Microsoft Translator) should
enter any valid URL.

) Enable subdomain access

Enables subdomains for the redirect URI to he specified when invoking the consent flow. In most scenarios, this

should remain unchecked.

Description

Optional description for the application, visible only to you.

CREATE

Client ID. Your application's ID. It can be a mix of numbers, letters, hyphens and underscores.
Name. The name of the application.

Client secret. Generated automatically.

Redirect URI. Enter URL of your website.

- Cancel

HINT: Client ID and Client secret should be used in settings of SEF Translate component.
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