OrdaSoft forum
Welcome, Guest
Please Login or Register.    Lost Password?
XML Import Large Files Causes Crash (0 viewing) 
BookLibary Component Support
Go to bottom Favoured: 0
TOPIC: XML Import Large Files Causes Crash
MyCatsHeaven (Visitor)
Posts: 0
graphgraph
User Offline
XML Import Large Files Causes Crash 11 Years, 9 Months ago
Karma: 0  
I tried to import 5,300 books with XML. The component appears to "crash" at around 300-500 records? I tried separating into 1,000-book files still with significant problems. Is it the component or my server causing the problem? Or, a global setting in Joomala?
Logged Logged
The administrator has disabled public write access.
admin (Admin)
Admin
Posts: 7451
graph
User Offline Click here to see the profile of this user
Re:XML Import Large Files Causes Crash 11 Years, 9 Months ago
Karma: 91  
What version you use ?
Logged Logged
The administrator has disabled public write access.
MyCatsHeaven (Visitor)
Posts: 0
graphgraph
User Offline
Re:XML Import Large Files Causes Crash 11 Years, 9 Months ago
Karma: 0  
v 1.5.3 Pro

Here's the message I get on IMPORT: Fatal error: Maximum execution time of 30 seconds exceeded in /usr/home/web/users/a0020367/html/libraries/joomla/database/database/mysql.php on line 223

I'm only able to import 500-600 records at a time.

Also unable to XML export. Get "whitespace" error on over 154 books in category.
Logged Logged
The administrator has disabled public write access.
admin (Admin)
Admin
Posts: 7451
graph
User Offline Click here to see the profile of this user
Re:XML Import Large Files Causes Crash 11 Years, 9 Months ago
Karma: 91  
With 30 seconds exceeded
Please ask yours host provider change "Maximum execution time" in PHP.INI

With other please check self email.

Thanks
Logged Logged
The administrator has disabled public write access.
MyCatsHeaven (Visitor)
Posts: 0
graphgraph
User Offline
Re:XML Import Large Files Causes Crash SOLVED 11 Years, 9 Months ago
Karma: 0  
yep... that's it! Add line in php.ini:

max_execution_time=300

Works great! Thanks.
Logged Logged
The administrator has disabled public write access.
Go to top