OrdaSoft forum
Welcome, Guest
Please Login or Register.    Lost Password?
booklibrary and php version (0 viewing) 
BookLibary Component Support
Go to bottom Favoured: 0
TOPIC: booklibrary and php version
#43979
enana (User)
Fresh Boarder
Posts: 6
graphgraph
User Offline Click here to see the profile of this user
booklibrary and php version 2 Weeks, 6 Days ago Karma: 0  
The installed booklibrary in our website is not working with php higher than PHP 7.0, Now many extensions not working on this version and I have to update it to 7.3

www.iraqinhistory.com/321/all_category
if you click on any category (on this page)you get this error

Too few arguments to function PHP_booklibrary:howItemBL(), 2 passed in /home/iraqinhistory/public_html/components/com_booklibrary/booklibrary.php on line 221 and exactly 3 expected

Please advice how to fix this error
 
Logged Logged  
  The administrator has disabled public write access.
#43986
admin (Admin)
Admin
Posts: 6971
graph
User Offline Click here to see the profile of this user
Re:booklibrary and php version 2 Weeks, 5 Days ago Karma: 82  
Hello

You have very old version of component. Please update to last version

Before making any upgrades, make backup yours site( files and DataBase). With that you will not lost something important
Please do full XML export.
At first please check upgrade/update process at the test website!
Please install new component and modules without remove old.

When component is updated, the update overwrites the Component configuration, please check component configuration.

If you have custom changes of component or site, you can lose your changes.

Please, in that case do not make update.

If you would like any further information, please do not hesitate to contact us too.

Best Wishes,
OrdaSoft team
P.S. Please do site backup 2 times per month if the more often - better!
 
Logged Logged  
  The administrator has disabled public write access.
Go to top
What are you looking for?
Anti-spam question: How many head has a typical person?